• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Visualizzazione risultati da 1 a 14 di 14

Discussione: Problema Ati

Cambio titolo
  1. #1
    Utente
    Registrato il
    06-04
    Messaggi
    264

    Problema Ati

    quando tento di installare i driver seguendo la guida, mi dice:

    [email protected] Desktop]# rpm -i --force fglrx-4.3.0-3.14.1.i386.rpm
    *** Trying to install a precompiled kernel module.
    *** WARNING ***
    Tailored kernel module for fglrx not present in your system.
    You must go to /lib/modules/fglrx/build_mod subdir
    and execute './make.sh' to build a fully customed kernel module.
    Afterwards go to /lib/modules/fglrx and run './make_install.sh'
    in order to install the module into your kernel's module repository.
    (see readme.txt for more details.)

    As of now you can still run your XServer in 2D, but hardware acclerated
    OpenGL will not work and 2D graphics will lack performance.

    failed.
    *** Error: no kernel module build environment - please consult readme.
    *** Warning ***
    The QT based control panel application did not load in any version.
    ===
    ATI display drivers successfully installed
    please run 'fglrxconfig' now


    che devo fare?

  2. #2
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    Località
    Midwich Street
    Messaggi
    6.699
    Secondo te?

    "You must go to /lib/modules/fglrx/build_mod subdir
    and execute './make.sh' to build a fully customed kernel module.
    Afterwards go to /lib/modules/fglrx and run './make_install.sh'
    in order to install the module into your kernel's module repository."


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  3. #3
    Utente
    Registrato il
    06-04
    Messaggi
    264
    si ma non me lo fa....., quello l ho letto anke io

  4. #4
    Utente
    Registrato il
    06-04
    Messaggi
    264
    ora mi da questo errore : [[email protected] build_mod]# ./make.sh
    ATI module generator V 2.0
    ==========================
    initializing...
    kernel includes at /usr/src/linux/include not found or incomplete
    file: /usr/src/linux/include/linux/version.h

  5. #5
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    Località
    Midwich Street
    Messaggi
    6.699
    Non hai installati i sorgenti del kernel.


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  6. #6
    Utente
    Registrato il
    06-04
    Messaggi
    264
    cosa devo fare? Ricompilare il kernel?

  7. #7
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    Località
    Midwich Street
    Messaggi
    6.699
    No, scompatta i sorgenti del kernel che stai usando nella directory /usr/src/ e crea il link simbolico "/usr/src/linux" che punti alla directory che ti si crea

    ad esempio:
    # ln -s /usr/src/linux-2.6.7 /usr/src/linux


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  8. #8
    Utente
    Registrato il
    06-04
    Messaggi
    264
    il problema è che non ho la cartella linux in usr/src

  9. #9
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    Località
    Midwich Street
    Messaggi
    6.699
    La cartella te la crea quando scompatti l'archivio dei sorgenti; "linux" è un link simbolico a quella cartella (che si chiamerà in altro modo).


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  10. #10
    Utente GNU/Linux
    Registrato il
    10-02
    Località
    Roma
    Messaggi
    3.246
    Che distribuzione usi? Quasi sicuramente dispone di un pacchetto contenente i sorgenti del kernel utilizzati.

  11. #11
    Utente
    Registrato il
    06-04
    Messaggi
    264
    usa mdk10

  12. #12
    Utente GNU/Linux
    Registrato il
    10-02
    Località
    Roma
    Messaggi
    3.246
    Citazione Hannibal
    usa mdk10
    Il pacchetto si chiama kernel-source, puoi installarlo dal gestore dei pacchetti (rpmdrake) o con il comando (da root) urpmi kernel-source .

  13. #13
    Utente
    Registrato il
    06-04
    Messaggi
    264
    io ho scaricato il kernel 2.6.8.1 da kernel.org, il file che ha scaricato si chiama patch-2.6.8.1, come faccio ad installarlo? Se scrivo rpmdrake mi da sta lista:

    [[email protected] gabriele]$ rpmdrake
    esamino il file synthesis [/var/lib/urpmi/synthesis.hdlist.Installation CD 1 (x86) (cdrom1).cz]
    esamino il file synthesis [/var/lib/urpmi/synthesis.hdlist.Installation CD 2 (x86) (cdrom2).cz]
    esamino il file synthesis [/var/lib/urpmi/synthesis.hdlist.Installation CD 3 (x86) (cdrom3).cz]
    esamino il file synthesis [/var/lib/urpmi/synthesis.hdlist.Installation CD 4 (x86) (cdrom4).cz]
    esamino il file synthesis [/var/lib/urpmi/synthesis.hdlist.update_source.cz]
    installerebbe il pacchetto kernel-2.4.25.8mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-2.4.25.2mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel2.4-marcelo-2.4.25-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-enterprise-2.6.3.16mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-p3-smp-64GB-2.6.3.16mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-i686-up-4GB-2.6.3.16mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-smp-2.4.25.2mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-i686-up-4GB-2.6.3.7mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-enterprise-2.4.25.2mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-i686-up-4GB-2.4.25.8mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-p3-smp-64GB-2.4.25.8mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-p3-smp-64GB-2.6.3.7mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-secure-2.6.3.7mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-enterprise-2.4.25.8mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-2.6.3.16mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-secure-2.6.3.16mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-p3-smp-64GB-2.4.25.2mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-2.6.3.7mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-smp-2.4.25.8mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-i686-up-4GB-2.4.25.2mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-enterprise-2.6.3.7mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-smp-2.6.3.16mdk-1-1mdk.i586 invece di aggiornarlo
    installerebbe il pacchetto kernel-smp-2.6.3.7mdk-1-1mdk.i586 invece di aggiornarlo
    [[email protected] gabriele]$

  14. #14
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    Località
    Midwich Street
    Messaggi
    6.699
    No.
    Digita 'uname -r' per vedere che versione del kernel hai; poi digita urpmi kernel-source-'versionekernel'.


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •