• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Visualizzazione risultati da 1 a 15 di 15

Discussione: installazione driver ati

Cambio titolo
  1. #1
    janky
    Ospite

    installazione driver ati

    sto provando ad installare i driver ati su una slackware, ma ricevo questo errore>
    Failed dependencies:
    /bin/sh is needed by fglrx-4.3.0-3.14.1
    ld-linux.so.2 is needed by fglrx-4.3.0-3.14.1
    libX11.so.6 is needed by fglrx-4.3.0-3.14.1
    libXext.so.6 is needed by fglrx-4.3.0-3.14.1
    libc.so.6 is needed by fglrx-4.3.0-3.14.1
    libdl.so.2 is needed by fglrx-4.3.0-3.14.1
    libm.so.6 is needed by fglrx-4.3.0-3.14.1
    libpthread.so.0 is needed by fglrx-4.3.0-3.14.1
    libc.so.6(GLIBC_2.0) is needed by fglrx-4.3.0-3.14.1
    libc.so.6(GLIBC_2.1) is needed by fglrx-4.3.0-3.14.1
    libc.so.6(GLIBC_2.1.3) is needed by fglrx-4.3.0-3.14.1
    libm.so.6(GLIBC_2.0) is needed by fglrx-4.3.0-3.14.1
    libpthread.so.0(GLIBC_2.0) is needed by fglrx-4.3.0-3.14.1


    cosa devo fare?

  2. #2
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    LocalitÓ
    Midwich Street
    Messaggi
    6.699


    che comando hai dato?
    fai un po' "ls /bin/bash && ls /bin/sh"...


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  3. #3
    janky
    Ospite
    mi ritorna
    /bin/bash
    /bin/sh

    il comando che ho dato e':
    rpm -ivh fglrx-4.3.0-3.14.1.i386.rpm --force

  4. #4
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    LocalitÓ
    Midwich Street
    Messaggi
    6.699
    Ah ma usi slackware, grazie a Gatsu.
    Devi convertire l'rpm in tgz con rpm2tgz e poi usare normalmente pkgtool per installarlo.


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  5. #5
    janky
    Ospite
    quindi devo scrivere questo:
    pkgtool -ivh fglrx-4.3.0-3.14.1.i386.tgz --force ?

  6. #6
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    LocalitÓ
    Midwich Street
    Messaggi
    6.699
    no non credo... sei te che usi slackware mica io
    dovrebbe essere "installpkg fglrx-4.3.0-3.14.1.i386.tgz" non so se ci sia (bisogno di) un'opzione per forzare l'installazione.


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  7. #7
    Utente Tostapane L'avatar di WarriorXP
    Registrato il
    10-02
    LocalitÓ
    MI C.le - LE
    Messaggi
    23.429
    Citazione Phoenix
    no non credo... sei te che usi slackware mica io
    dovrebbe essere "installpkg fglrx-4.3.0-3.14.1.i386.tgz" non so se ci sia (bisogno di) un'opzione per forzare l'installazione.
    No, no, che --force... E' un gestore di pacchetti serio, questo

  8. #8
    janky
    Ospite
    e che ne s˛ io....sono n00b uso slackware perchŔ la devo imparare per scuola...

    aiutatemi

    cmq ora provo con installpkg

  9. #9
    janky
    Ospite
    ok, ho dato
    # installpkg fglrx-4.3.0-3.14.1.i386.tgz

    mi viene fuori:

    Installing package fglrx-4.3.0-3.14.1.i386...
    PACKAGE DESCRIPTION:

    e poi basta.... che devo fa'??

  10. #10
    janky
    Ospite
    dopo quello che ho scritto nel mex precedente do' fglrxconfig, faccio la configurazione e riavvio x, pero' quando faccio fglrxinfo mi dice che usa ancora i driver mesa... he devo fa'?

  11. #11
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    LocalitÓ
    Midwich Street
    Messaggi
    6.699
    modprobe fglrx

    Ma la guida la leggesti?


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  12. #12
    janky
    Ospite
    Citazione Phoenix
    modprobe fglrx

    Ma la guida la leggesti?
    si', pero' quando tento di fare (come dice nella guida) modprobe agpgart mi dice:

    /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: init_module: No such device
    /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg
    /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: insmod /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz failed
    /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: insmod agpgart failed

  13. #13
    Utente Gentoo Gnu/Linux L'avatar di []\/[]aStEr-HaCk
    Registrato il
    06-03
    LocalitÓ
    /dev/sda6
    Messaggi
    1.663
    Citazione janky
    si', pero' quando tento di fare (come dice nella guida) modprobe agpgart mi dice:

    /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: init_module: No such device
    /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg
    /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: insmod /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz failed
    /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: insmod agpgart failed
    I misteri di SLACCKAWARE


    [email protected] ~ $ uname -a
    Linux venice64 2.6.15-gentoo-r5 #1 Wed Apr 12 18:48:03 GMT 2006 x86_64 AMD Athlon(tm) 64 Processor 3500+ AuthenticAMD GNU/Linux

  14. #14
    Utente Tostapane L'avatar di WarriorXP
    Registrato il
    10-02
    LocalitÓ
    MI C.le - LE
    Messaggi
    23.429
    Citazione janky
    dopo quello che ho scritto nel mex precedente do' fglrxconfig, faccio la configurazione e riavvio x, pero' quando faccio fglrxinfo mi dice che usa ancora i driver mesa... he devo fa'?
    Devi modificare delle voci in xorg.conf in base ai tuoi driver mi sa...
    I misteri di SLACCKAWARE
    Adesso ti mattonifico

  15. #15
    janky
    Ospite
    ho dovuto ricompilare il kernel e abilitare il modulo agpgart, poi sono riuscito ad installare correttamente i driver

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •