• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Visualizzazione risultati da 1 a 14 di 14

Discussione: Problema con java su Windows 98

Cambio titolo
  1. #1
    .::D TVB::. L'avatar di [>>VK<<]
    Registrato il
    02-04
    Località
    In Your Mind
    Messaggi
    2.864

    Esclamazione Problema con java su Windows 98

    Mi sto laureando in comunicazione digitale a Milano, per fare le esercitazioni che ci assegnano ho istallato Java sul computer di casa ( e qui mi funziona alla perfezione); e sul computer che ho in appartamento a Milano.
    Il problema che Java nel mio vecchio computer di Milano non vuole proprio andare;mi spiego meglio: ho istallato Java e l'editor che uso per programmare in java (ginipad), ho settato PATH e CLASSPATH,quando compilo tutto liscio me lo compila e mi genera il file .class, il problema arriva quando provo a eseguire il programma in dos ; digito le parole magiche java NomeProgramma e do invio, ma la JVM mi da lo stesso errore di quando si sbaglia il nome del programma (Exception in thread "main" java.lang.NoClassDefFoundError: NomeProgramma ).
    Da cosa puo essere causato tale errore ? mi seve aiuto Please.

    P.S

    A casa Java lo uso su Win XP e come detto tutto liscio.

    Si cercano collaboratori per il sito se siete interessati contattatemi via MP

  2. #2
    .::D TVB::. L'avatar di [>>VK<<]
    Registrato il
    02-04
    Località
    In Your Mind
    Messaggi
    2.864
    nessuno mi sa aiutare

    Si cercano collaboratori per il sito se siete interessati contattatemi via MP

  3. #3
    Utente L'avatar di pentothal
    Registrato il
    10-02
    Località
    Firenze
    Messaggi
    4.692
    Non saprei dato che codesto errore viene dato per svariati motivi, ma se vuoi un altro aiuto valido e immediato, vai sul forum di http://www.mokabyte.it , sapranno sicuramente risponderti...

  4. #4
    .::D TVB::. L'avatar di [>>VK<<]
    Registrato il
    02-04
    Località
    In Your Mind
    Messaggi
    2.864
    Citazione pentothal
    Non saprei dato che codesto errore viene dato per svariati motivi, ma se vuoi un altro aiuto valido e immediato, vai sul forum di http://www.mokabyte.it , sapranno sicuramente risponderti...
    Ma sto forum è a pagamento come si fa a registrarsi???

    Si cercano collaboratori per il sito se siete interessati contattatemi via MP

  5. #5
    P.D. bestemmia L'avatar di asdrubale88
    Registrato il
    05-03
    Località
    Brescia
    Messaggi
    5.697
    può darsi che sia colpa della virtual machine di windows, che è diversa da quella della sun
    vai a capire zio bill, io glielo avevo detto di usare la loro, ma lui ha detto che chi fa da sè fa per tre (bug in più )

    e quindi la soluzione è formattare
    oppure, un'alternativa, è non ascoltare in nessun caso i miei consigli

  6. #6
    SCM StarCraft Mapper L'avatar di Wolf01[WDD]
    Registrato il
    06-03
    Località
    SMT
    Messaggi
    3.882
    ad un mio amico dava quell'errore, e anke lui nn capiva xkè...
    io mi sn accorto ke il nome del file .java e il nome del programma erano diversi (e di conseguenza anke il nome del file .java e quello .class erano diversi), quando lo esegui devi mettere il nome del .class non del.java

  7. #7
    ~ Over My Head ~ L'avatar di Finalfire
    Registrato il
    06-03
    Località
    Italy
    Messaggi
    5.013
    Citazione Wolf01[WDD]
    ad un mio amico dava quell'errore, e anke lui nn capiva xkè...
    io mi sn accorto ke il nome del file .java e il nome del programma erano diversi (e di conseguenza anke il nome del file .java e quello .class erano diversi), quando lo esegui devi mettere il nome del .class non del.java
    Beh, credo che lo desse per scontanto.
    E' ovvio che la classe è il nome del file devono essere gli stessi

  8. #8
    .::D TVB::. L'avatar di [>>VK<<]
    Registrato il
    02-04
    Località
    In Your Mind
    Messaggi
    2.864
    Citazione Wolf01[WDD]
    ad un mio amico dava quell'errore, e anke lui nn capiva xkè...
    io mi sn accorto ke il nome del file .java e il nome del programma erano diversi (e di conseguenza anke il nome del file .java e quello .class erano diversi), quando lo esegui devi mettere il nome del .class non del.java
    Si questo lo sapevo già , infatti come Prova ho usato programmi che sul computer di casa ( con XP) funzionano alla perfezione. il nome lo digitato giusto al 100%

    Si cercano collaboratori per il sito se siete interessati contattatemi via MP

  9. #9
    EX-TER-MI-NA-TE! L'avatar di lord mark 87
    Registrato il
    01-03
    Località
    Legen-wait for it-DARY
    Messaggi
    51.381
    anche a me oggi faceva così

    dovrei riprovare a reinstallare le librerie

  10. #10
    violentissimo L'avatar di [thegreatdeceiver]
    Registrato il
    09-03
    Località
    in un buco di culo
    Messaggi
    1.909
    Prova a effettuare la compilazione e il run con un IDE. Procurati BlueJ, Eclipse o ancora meglio JBuilder...

  11. #11
    SCM StarCraft Mapper L'avatar di Wolf01[WDD]
    Registrato il
    06-03
    Località
    SMT
    Messaggi
    3.882
    anke JCreator ke è free ed è abbastanza carino

  12. #12
    .::D TVB::. L'avatar di [>>VK<<]
    Registrato il
    02-04
    Località
    In Your Mind
    Messaggi
    2.864
    ma i .class sul computer di casa mi funzionano e solo li che fa cosi.

    Si cercano collaboratori per il sito se siete interessati contattatemi via MP

  13. #13
    SCM StarCraft Mapper L'avatar di Wolf01[WDD]
    Registrato il
    06-03
    Località
    SMT
    Messaggi
    3.882
    Citazione [>>VK<<]
    ma i .class sul computer di casa mi funzionano e solo li che fa cosi.
    hai settato le variabili d'ambiente?
    anke se penso ke nn centri molto, visto ke se nn sono settate ti dà "java: comando non trovato, controllare la sintassi e riprovare"

  14. #14
    .::D TVB::. L'avatar di [>>VK<<]
    Registrato il
    02-04
    Località
    In Your Mind
    Messaggi
    2.864
    Citazione Wolf01[WDD]
    hai settato le variabili d'ambiente?
    anke se penso ke nn centri molto, visto ke se nn sono settate ti dà "java: comando non trovato, controllare la sintassi e riprovare"

    non chiedetemi perchè ma ho controllato le variabili di ambiente e mi sono dimenticato di aggiungere %classpath% e %path%, alla fine della stringa di comando, quando ho riavviato andata vutto alla perfezione.
    Però mi chiedo come faceva a compilare se le variabili erano incomplete??

    Si cercano collaboratori per il sito se siete interessati contattatemi via MP

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •