• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Pag 1 di 2 12 UltimoUltimo
Visualizzazione risultati da 1 a 15 di 18

Discussione: headers python

Cambio titolo
  1. #1
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864

    headers python

    ho bisogno di installaregli headers di python perche me lo richiede pygtk e gnome-python al momento del ./configure. Ho scaricato Python-1.5.2-mingw32.zip ma nn so come usarlo, nel senso che nn so dove mettere i file dell'archivio.

  2. #2
    Utente GNU/Linux
    Registrato il
    10-02
    LocalitÓ
    Roma
    Messaggi
    3.246
    Citazione Dark Ares
    ho bisogno di installaregli headers di python perche me lo richiede pygtk e gnome-python al momento del ./configure. Ho scaricato Python-1.5.2-mingw32.zip ma nn so come usarlo, nel senso che nn so dove mettere i file dell'archivio.
    Non usare le tarballs (.tar.gz , .tar.bz2 , .tgz), usa gli RPM su Mandrake.
    Aggiungi una sorgente al tuo gestore di pacchetti, puoi aiutarti dal sito http://easyurpmi.zarb.org/ (sorgenti contrib e plf , se hai tutti e 3 i CD); poi se vorrai usare un'interfaccia grafica, dal men¨ trova qualcosa come "Installazione Software" o cmq accedi al gestore di pacchetti # rpmdrake , in alternativa da riga di comando basterÓ:
    # urpmi pacchetto
    ad esempio: # urpmi gdesklets
    Per gli headers di Python non dovresti manco avere bisogno d'aggiungere sorgenti, mi risulta siano inclusi nei CD di Mandrake... (# urpmi libpython2.3-devel )

  3. #3
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864
    appunto come hai intuito stavo cercando di installare gdesklets, ma mi richiede parecchi pacchetti che cercavo di installare, ognuno dei quali chiedeva altri pacchetti...

  4. #4
    Utente GNU/Linux
    Registrato il
    10-02
    LocalitÓ
    Roma
    Messaggi
    3.246
    Citazione Dark Ares
    appunto come hai intuito stavo cercando di installare gdesklets, ma mi richiede parecchi pacchetti che cercavo di installare, ognuno dei quali chiedeva altri pacchetti...
    Ripeto, usa gli RPM, il gestore di pacchetti si occuperÓ automaticamente di risolvere le dipendenze, scaricare ed installare tutti i pacchetti necessari, risparmiandoti configurazioni, compilazioni, e soprattutto conflitti.

  5. #5
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864
    allora percio scarico il rpm di gdesklets?
    e poi come lo faccio configurare sotto Mandrake 10?

  6. #6
    Utente GNU/Linux
    Registrato il
    10-02
    LocalitÓ
    Roma
    Messaggi
    3.246
    Citazione Dark Ares
    allora percio scarico il rpm di gdesklets?
    e poi come lo faccio configurare sotto Mandrake 10?
    Se fai come ti ho suggerito al 2░ post non devi manco cercare l'RPM di gDesklets , fa tutto il gestore di pacchetti di MDK, devi solo aggiungergli le sorgenti, per esempio (per Mandrake 10.1 ufficiale):
    Codice:
    # urpmi.addmedia contrib ftp://bo.mirror.garr.it/mirrors/Mandrake/official/10.1/i586/media/contrib with media_info/hdlist.cz
    O per gli aggiornamenti:
    Codice:
    # urpmi.addmedia --update updates ftp://bo.mirror.garr.it/mirrors/Mandrake/official/updates/10.1/main_updates with media_info/hdlist.cz
    Poi installi quello che vuoi con # urpmi pacchetto
    oppure # rpmdrake
    (cmq c'Ŕ la voce nel men¨ per rpmdrake, "Installazione Software" o qualcosa di analogo)

    Se vuoi software pi¨ esotico (sempre per MDK 10.1 Official) aggiungi anche questa sorgente:
    # urpmi.addmedia plf ftp://spirit.bentel.sk/mirrors/plf/mandrake/10.1 with hdlist.cz
    Ultima modifica di Nonno Cicala; 23-01-2005 alle 15:39:30

  7. #7
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864
    ma quei codici dove li metto? Sono per scaricare gdesklets?

  8. #8
    Utente GNU/Linux
    Registrato il
    10-02
    LocalitÓ
    Roma
    Messaggi
    3.246
    Citazione Dark Ares
    ma quei codici dove li metto?
    # e $ non vanno digitati, indicano il tipo di shell:
    # = shell di root (Konsole di root)
    $ = shell utente

    Sono per fare in modo che il gestore di pacchetti si occupi d'ora in poi di scaricare ed installare automaticamente tutto quello che si vuole, senza pi¨ dover cercare files su internet, nŔ risolverne le dipendeze (pacchetti prerequisiti), nŔ compilarli, e stando tranquilli che non si creino conflitti o roba del genere.

    N.B.:Per˛ quei comandi sono per Mandrake 10.1 Official, tu esattamente quale hai installato?

  9. #9
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864
    ho la 10.0, ora provo a farli

  10. #10
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864
    quei comandi nn vanno bene, ovvero dice che nn riesce a recuperare i vari file. Mi dici quello esatto per le gdesklets, plz?

  11. #11
    Utente GNU/Linux
    Registrato il
    10-02
    LocalitÓ
    Roma
    Messaggi
    3.246
    Citazione Dark Ares
    quei comandi nn vanno bene, ovvero dice che nn riesce a recuperare i vari file. Mi dici quello esatto per le gdesklets, plz?
    No, perchÚ con il solo RPM di gDesklets fai ben poco (e quello che vedo nel tuo screenshot nell'altro thread mi sembra anche l'RPM sbagliato).
    Non ti ho messo l'indirizzo di http://easyurpmi.zarb.org/ a caso, perchÚ vuoi complicare la vita a te e a noi?

    Va be'...
    1. Vedi se la tua Mandrake Ŕ la 10.0 Community o Official
    2. Vai su http://easyurpmi.zarb.org/?language=it
    3. Seleziona la versione della tua Mandrake dall'apposito men¨ a tendina
    4. Clicca su "procedi al passo 2"
    5. Seleziona dai men¨ a tendina contrib, updates e plf dei servers vicini a dove ti trovi (c'Ŕ la nazione a fianco dell'indirizzo)
    6. Clicca "procedi al passo 3"
    7. Appariranno tre comandi scritti bianco su nero, dalli in una shell di root (es.: Konsole di root)
    Da questo punto in poi dovresti poter installare quello che vuoi con le utility di Mandrake (urpmi, rpmdrake, es.: # urpmi gdesklets ).

  12. #12
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864
    grazie ora lo faccio

  13. #13
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864
    percio faccio tutti i passi detti da te e poi a operazione completa faccio urpmi gdesklets, giusto?

  14. #14
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864
    cmq ho scaricato contrib, main, plf,. Poi "altre fonti" club, jpackage, ovvero tutto il possibile scaricabile da quella pagina. Mo sto a fini contrib e poi vediamo come va a fini....

  15. #15
    Fighting with Mandrake L'avatar di Dark Ares
    Registrato il
    01-04
    LocalitÓ
    Russia
    Messaggi
    864
    fatto tutto quello che hai detto tu con un piccolo problema: quando scrivo urpmi gdesklets mi dice:
    Alcuni dei pacchetti richiesti nn possono essere installati:
    gdesklets-0.33-1.1.fc4.rf.i386 (perche nn e' soddisfatto gnome-python2[>= 1.99.17]) 9S/
    n)

    Ti prego aiutami, sei un dio..

Pag 1 di 2 12 UltimoUltimo

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •