• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Visualizzazione risultati da 1 a 6 di 6

Discussione: Canon i250 drivers per Fedora3

Cambio titolo
  1. #1
    Utente L'avatar di LarsGuardian
    Registrato il
    12-02
    Localit
    Di nuovo in Italia...
    Messaggi
    266

    Canon i250 drivers per Fedora3

    Ciao ho dei problemi a installare i driver per questa stampante
    Ho trovato i dirver sul sito canon.nz:
    http://www.canon.co.nz/products/prin...0_drivers.html
    e gi iniziano le probleme:

    ci sono tante versioni e CUPS. Cosa sono i CUPS?

    Non sapevo quale installare, cosi ho installato il primo
    Nell file install mi dice che devo installare automake e autoconf quindi scarico e installo automake 1.3 e autoconf 2.59 dal sito ftp.gnu.org

    Il file Install dei driver dice di scrivere:

    .autogen.sh --program-suffix=i250
    make
    make install

    ma gi al primo comando mi da questo errore:

    [[email protected] bjfilter-2.3-0]# ./autogen.sh --program-suffix=i250
    processing .
    Running aclocal ...
    Running autoheader...
    autoheader: WARNING: Using auxiliary files such as `acconfig.h', `config.h.bot'
    autoheader: WARNING: and `config.h.top', to define templates for `config.h.in'
    autoheader: WARNING: is deprecated and discouraged.
    autoheader:
    autoheader: WARNING: Using the third argument of `AC_DEFINE' and
    autoheader: WARNING: `AC_DEFINE_UNQUOTED' allows to define a template without
    autoheader: WARNING: `acconfig.h':
    autoheader:
    autoheader: WARNING: AC_DEFINE([NEED_FUNC_MAIN], 1,
    autoheader: [Define if a function `main' is needed.])
    autoheader:
    autoheader: WARNING: More sophisticated templates can also be produced, see the
    autoheader: WARNING: documentation.
    aclocal.m4:49: error: m4_defn: undefined macro: _m4_divert_diversion
    autoconf/oldnames.m4:113: AM_PROG_INSTALL is expanded from...
    aclocal.m4:49: the top level
    autom4te: /usr/bin/m4 failed with exit status: 1
    autoheader: /usr/local/bin/autom4te failed with exit status: 1
    Running automake --gnu ...
    Running autoconf ...
    aclocal.m4:49: error: m4_defn: undefined macro: _m4_divert_diversion
    autoconf/oldnames.m4:113: AM_PROG_INSTALL is expanded from...
    aclocal.m4:49: the top level
    autom4te: /usr/bin/m4 failed with exit status: 1
    Running ./configure --program-suffix=i250 ...
    ./autogen.sh: line 144: ./configure: No such file or directory

    Avete suggerimenti?
    Twirling round with this familiar parable.
    Spinning, weaving round each new experience.
    Recognize this as a holy gift and celebrate this chance to be alive and breathing.

  2. #2
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    CUPS il sistema standard di stampa in unix. che distribuzione usi?

  3. #3
    Utente GNU/Linux
    Registrato il
    10-02
    Localit
    Roma
    Messaggi
    3.246
    CUPS = Common Unix Printing System

  4. #4
    Utente L'avatar di LarsGuardian
    Registrato il
    12-02
    Localit
    Di nuovo in Italia...
    Messaggi
    266
    Citazione devilheart
    CUPS il sistema standard di stampa in unix. che distribuzione usi?
    E' scritto nel titolo: Fedora Core 3

    Ora s cosa sono i CUPS, ma mi aiutate per favore a risolvere l'errore???
    Grazie
    Twirling round with this familiar parable.
    Spinning, weaving round each new experience.
    Recognize this as a holy gift and celebrate this chance to be alive and breathing.

  5. #5
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    i pacchetti autoconf e automake dovrebbero essere installati automaticamente. controlla se hai installato tutti i pacchetti di sviluppo

  6. #6
    Utente GNU/Linux
    Registrato il
    10-02
    Localit
    Roma
    Messaggi
    3.246
    Io lascerei stare la tarball (il file .tar.gz).
    Hai prima provato a vedere se Fedora riconoscesse la stampante e fosse in grado di farla funzionare?

    Ho visto che esistono dei drivers per la BJC-250, ma siccome un modello BJC-250 sembra non esista fra le Canon (secondo il sito), essendo la i250 della stessa famiglia, anche se con nome diverso, proverei a configurarla come BJC-250 (sempre che Fedora non la riconosca e faccia funzionare automaticamente).

    In alternativa installa il pacchetto RPM per CUPS (# non va digitato, indica che il comando va dato da una shell di root):
    # rpm -Uvh nomefile.rpm

    Cerca di evitare le tarballs (.tar.gz , .tar.bz2 , .tgz) finch non sei abbastanza pratico e non sai bene cosa fare.

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •