• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Visualizzazione risultati da 1 a 5 di 5

Discussione: Column count doesn't match value count at row 1

Cambio titolo
  1. #1
    Demiurgo L'avatar di Bisark
    Registrato il
    03-03
    Località
    Vengo dalla Luna(Foligno)
    Messaggi
    10.444

    Column count doesn't match value count at row 1

    Ieri ho fatto un scirptino in php per aggiungere dei dati tramite un form html ad un database mysq e tutto funzionava all grande. questa matitna ho fatot delle modifiche aggiungendo nuove righe, ma non modificando neinte di significativo, ma qunado vado ad agigungere i dati mi da quest'errore.
    Column count doesn't match value count at row 1

    Questo invece è il codice che uso.
    Codice PHP:
    $inserimento mysql_query ("INSERT INTO torneo (id, name, realname, song, born, home, heigh, weigh, strikem, image, flym, hardcorem, finisher, win, fisico, style, bios)
     VALUES ('', '
    $HTTP_GET_VARS[name]', '$HTTP_GET_VARS[realname]', '$HTTP_GET_VARS[song]', '$HTTP_GET_VARS[born]', '$HTTP_GET_VARS[home]', '$HTTP_GET_VARS[heigh]', '$HTTP_GET_VARS[weigh]', '$HTTP_GET_VARS[strikem]', '$HTTP_GET_VARS[flym]', '$HTTP_GET_VARS[hardcorem]', '$HTTP_GET_VARS[finisher]', '$HTTP_GET_VARS[image]', '$HTTP_GET_VARS[fisico]', '$HTTP_GET_VARS[syle]', '$HTTP_GET_VARS[bios]')")
      or die(
    "Inserimento non riuscito: " mysql_error()); 
    L'utente in questione ha abbandonato il forum perché crede che da qualche anno a questa parte l'amministrazione dello stesso sia diventata semplicemente ridicola. Il modo in cui sono riusciti a burocratizzare e rendere meno piacevole un forum in cui la gente dovrebbe divertirsi e discutere insieme è disgustoso.
    Ed ora ci si mettono pure i banner parlanti!

  2. #2
    Demiurgo L'avatar di Bisark
    Registrato il
    03-03
    Località
    Vengo dalla Luna(Foligno)
    Messaggi
    10.444
    Ok ho risolto da solo. Forse prima di postare dovevo controllare meglio

    E che mi sono scordato di aggiunere $HTTP_GET_VARS[win]
    L'utente in questione ha abbandonato il forum perché crede che da qualche anno a questa parte l'amministrazione dello stesso sia diventata semplicemente ridicola. Il modo in cui sono riusciti a burocratizzare e rendere meno piacevole un forum in cui la gente dovrebbe divertirsi e discutere insieme è disgustoso.
    Ed ora ci si mettono pure i banner parlanti!

  3. #3
    Utente Tostapane L'avatar di WarriorXP
    Registrato il
    10-02
    Località
    MI C.le - LE
    Messaggi
    23.429
    Però l'uso di $HTTP_GET_VARS[nomevar] è deprecato a favore di $_GET['nomevar'], nel caso di aggiornamenti al webserver potresti trovarti lo script non funzionante.

  4. #4
    Demiurgo L'avatar di Bisark
    Registrato il
    03-03
    Località
    Vengo dalla Luna(Foligno)
    Messaggi
    10.444
    detto in parole povere?
    L'utente in questione ha abbandonato il forum perché crede che da qualche anno a questa parte l'amministrazione dello stesso sia diventata semplicemente ridicola. Il modo in cui sono riusciti a burocratizzare e rendere meno piacevole un forum in cui la gente dovrebbe divertirsi e discutere insieme è disgustoso.
    Ed ora ci si mettono pure i banner parlanti!

  5. #5
    Utente
    Registrato il
    06-04
    Località
    Padova
    Messaggi
    13
    Praticamente se aggiornano la versione del webserver dove ormai il l'uso di $HTTP_GET_VARS[nomevar] è deprecato quindi non funziona più il tuo codice non funziona. Il consiglio è usare $_GET['nomevar'].

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •