• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Visualizzazione risultati da 1 a 9 di 9

Discussione: Problemi con l'HTML - errori fasulli?!?

Cambio titolo
  1. #1
    Utente Tostapane L'avatar di WarriorXP
    Registrato il
    10-02
    Località
    MI C.le - LE
    Messaggi
    23.429

    Problemi con l'HTML - errori fasulli?!?

    Siccome non voglio essere accusato di spamming, chi se ne intende di html ed è consapevole di andare sulla pagina che ho scritto continui a leggere, chi non vuole leggere l'URL di un altro sito vada su un altro topic.

    Chiarita questa cosa passo al dunque:

    In questa pagina:
    Spoiler:
    www.lucugnano.it/Galeazzo.html
    Internet Explorer mi segnala un errore alla riga 104!! Dice che era prevista una parentesi chiusa!!

    Ho controllato il code della pagina palmo a palmo ma non manca proprio nulla!

    Qualcuno mi sa spiegare il problema?

    Ci terrei a risolverlo perchè un visitatore sprovveduto che si ritrova davanti un messaggio del tipo "eseguire il debug" si impantana più che volentieri.....

    GRAZIE MILLE A TUTTI COLORO CHE VORRANNO AIUTARMI!!

  2. #2
    Oh my iPod! L'avatar di er patata
    Registrato il
    11-02
    Località
    Bari Downtown
    Messaggi
    13.136
    da me non da errori

    A volte credo di essere fin troppo nerd. Naa, never too much.
    Vuoi personalizzare l'aspetto del forum di GamesRadar? Clicca qui!
    Consortium.ru 2004 3D Motion Demo, shocking graphics. (QuickTime 60MB)

    Vuoi guadagnare soldi velocemente? Clicca qui!

  3. #3
    Utente Tostapane L'avatar di WarriorXP
    Registrato il
    10-02
    Località
    MI C.le - LE
    Messaggi
    23.429

  4. #4
    Vampyrotheutis Infernalis L'avatar di Necromancer
    Registrato il
    10-02
    Località
    Palermo
    Messaggi
    6.615
    quando avevo windows XP mi capitava spesso di incontrare in diverse pagine l'errore id debug basta ceh cliccchi no e nn fa nulla..........
    winzozz XP=*****

  5. #5
    Utente GNU/Linux
    Registrato il
    10-02
    Località
    Roma
    Messaggi
    3.246
    La spiegazione è semplice, IE è buggato
    Nella tua pagina ci sono alcune cosette che andrebbero sistemate.
    Bisognerebbe aggiungere un DTD (doctype), specificare l'encoding, togliere lo <style></style> assolutamente inutile alla 6° riga (o ha qualche scopo?) ed aggiungere l'attributo alt=titoloimmagine al Logo.jpg , riga 10 .
    Questo perfezionerebbe il codice, mentre per quanto riguarda il contenuto, l'immagine Personaggi_Galeazzo.jpg è enorme, anche se l'hai impostata per una visualizzazione più piccola, il browser deve comunque scaricare l'originale prima di scalarlo... inoltre la risoluzione che hai dato non rispetta le proporzioni, deformandola; sarebbe più indicato usare un'immagine ridimensionata, come questa:

    che mantiene le proporzioni, occupa circa 1/8 dello spazio, ed avendo quasi la stessa altezza non aumenta il consumo di rotelline (preservando il layout)
    Ultima modifica di Nonno Cicala; 4-09-2003 alle 02:24:53

  6. #6
    Oh my iPod! L'avatar di er patata
    Registrato il
    11-02
    Località
    Bari Downtown
    Messaggi
    13.136
    nonno cicala è proprio un mito.....

    A volte credo di essere fin troppo nerd. Naa, never too much.
    Vuoi personalizzare l'aspetto del forum di GamesRadar? Clicca qui!
    Consortium.ru 2004 3D Motion Demo, shocking graphics. (QuickTime 60MB)

    Vuoi guadagnare soldi velocemente? Clicca qui!

  7. #7
    Polygon Window L'avatar di Stix
    Registrato il
    05-03
    Località
    Chieri(TO)
    Messaggi
    4.043
    Inviato da er patata
    nonno cicala è proprio un mito.....
    Quoto...
    Bravissimo

  8. #8
    Utente Tostapane L'avatar di WarriorXP
    Registrato il
    10-02
    Località
    MI C.le - LE
    Messaggi
    23.429
    Inviato da Nonno Cicala
    La spiegazione è semplice, IE è buggato
    Nella tua pagina ci sono alcune cosette che andrebbero sistemate.
    Bisognerebbe aggiungere un DTD (doctype), specificare l'encoding, togliere lo <style></style> assolutamente inutile alla 6° riga (o ha qualche scopo?) ed aggiungere l'attributo alt=titoloimmagine al Logo.jpg , riga 10 .
    Questo perfezionerebbe il codice, mentre per quanto riguarda il contenuto, l'immagine Personaggi_Galeazzo.jpg è enorme, anche se l'hai impostata per una visualizzazione più piccola, il browser deve comunque scaricare l'originale prima di scalarlo... inoltre la risoluzione che hai dato non rispetta le proporzioni, deformandola; sarebbe più indicato usare un'immagine ridimensionata, come questa:

    che mantiene le proporzioni, occupa circa 1/8 dello spazio, ed avendo quasi la stessa altezza non aumenta il consumo di rotelline (preservando il layout)
    OK l'ottimizzazzione delle pagine ma a me serve più che altro risolvere il problema. Proverò con il doctype e l'encoding ma il resto non penso sia utile all'errore. Cmq grazie nonno

  9. #9
    Utente GNU/Linux
    Registrato il
    10-02
    Località
    Roma
    Messaggi
    3.246
    Inviato da WarriorXP
    OK l'ottimizzazzione delle pagine ma a me serve più che altro risolvere il problema. Proverò con il doctype e l'encoding ma il resto non penso sia utile all'errore. Cmq grazie nonno
    La tag <style> manca dell'attributo type, è un errore ed anche per questo ti ho suggerito di toglierla, visto che è vuota e quindi non fa altro che rovinare il codice ed occupare una dozzina di bytes
    Riguardo l'attributo alt del Logo.jpg , per IE non dovrebbe essere un problema, per altri browsers potrebbe, ma comunque non ti conviene avere una pagina in HTML 4.01 Transitional valida semplicemente aggiungendo due parole?
    Se la pagina fosse valida (quindi con le modifiche specificate nel post precedente) e continuasse a dare lo stesso errore, sarebbe necessariamente un bug di IE, che necessita di un work-around che ti toccherà cercare. Cmq c'è un semplice sistema per risolvere tutti questi problemi... mettere in prima pagina un bel collegamento al Mozilla!

    Ringrazio tutti dei complimenti

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •