• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Pag 1 di 2 12 UltimoUltimo
Visualizzazione risultati da 1 a 15 di 19

Discussione: linux e isdn

Cambio titolo
  1. #1
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311

    linux e isdn

    c' qualcuno che si intende di isdn sotto linux? questo quello che succede se scrivo isdn start:
    Loading HiSax driver
    CardID: 12
    CardType: 12
    CardName: ASUS COM ISDNLink
    Parameters: id=12 irq=5 io=0xb800
    Configuring kernel for dynamic ip re-routing
    /dev/isdnctrl: No such device
    Starting iprofd ...
    /dev/isdninfo: No such device
    /dev/isdnctrl: No such device

    la versione del kernel 2.6.0-test11

  2. #2
    Utente Gentoo Gnu/Linux L'avatar di []\/[]aStEr-HaCk
    Registrato il
    06-03
    Localit
    /dev/sda6
    Messaggi
    1.663

    Re: linux e isdn

    Inviato da devilheart
    c' qualcuno che si intende di isdn sotto linux? questo quello che succede se scrivo isdn start:
    Loading HiSax driver
    CardID: 12
    CardType: 12
    CardName: ASUS COM ISDNLink
    Parameters: id=12 irq=5 io=0xb800
    Configuring kernel for dynamic ip re-routing
    /dev/isdnctrl: No such device
    Starting iprofd ...
    /dev/isdninfo: No such device
    /dev/isdnctrl: No such device

    la versione del kernel 2.6.0-test11
    Io non me ne intendo, ma perch non provi a mettere un Kernel pi stabile??


    [email protected] ~ $ uname -a
    Linux venice64 2.6.15-gentoo-r5 #1 Wed Apr 12 18:48:03 GMT 2006 x86_64 AMD Athlon(tm) 64 Processor 3500+ AuthenticAMD GNU/Linux

  3. #3
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    nn un problema di stabilit. cmq con il 2.4.22 funziona

  4. #4
    Utente Gentoo Gnu/Linux L'avatar di []\/[]aStEr-HaCk
    Registrato il
    06-03
    Localit
    /dev/sda6
    Messaggi
    1.663
    Inviato da devilheart
    nn un problema di stabilit. cmq con il 2.4.22 funziona
    Allora aspetta che esca la versione finale(e stabile) del kernel 2.6 e poi ricompili il kernel. Tanto non manca molto, Linus ci far il regalo per Natale


    [email protected] ~ $ uname -a
    Linux venice64 2.6.15-gentoo-r5 #1 Wed Apr 12 18:48:03 GMT 2006 x86_64 AMD Athlon(tm) 64 Processor 3500+ AuthenticAMD GNU/Linux

  5. #5
    Utente GNU/Linux
    Registrato il
    10-02
    Localit
    Roma
    Messaggi
    3.246

    Re: linux e isdn

    Inviato da devilheart
    c' qualcuno che si intende di isdn sotto linux? questo quello che succede se scrivo isdn start:
    Loading HiSax driver
    CardID: 12
    CardType: 12
    CardName: ASUS COM ISDNLink
    Parameters: id=12 irq=5 io=0xb800
    Configuring kernel for dynamic ip re-routing
    /dev/isdnctrl: No such device
    Starting iprofd ...
    /dev/isdninfo: No such device
    /dev/isdnctrl: No such device

    la versione del kernel 2.6.0-test11
    Avevo la stessa scheda ISDN prima di passare a FastWeb, e come hai detto funziona benissimo con i kernels della serie 2.4 .
    Hai abilitato DevFS nel kernel? Sembra ti manchino i device files generalmente creati dal DevFS ( in /dev ), che tuttavia ha subito alcune modifiche nel 2.6 , non so quali riguardino il supporto ISDN.

  6. #6
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    sono riuscito a caricare il driver e ad attivare l'interfaccia ippp0. ora per collegarmi digito 'isdnctrl dial ippp0' e viene scritto dialing of ippp0 triggered. se digito 'isdnctrl status ippp0' viene scritto ippp0 not connected.

  7. #7
    Contegno, suvvia! L'avatar di Prometeo
    Registrato il
    10-02
    Localit
    New York
    Messaggi
    7.890
    Hai settato l'autenticazione PAP?
    the e.caffeinomane Xperience
    <Drg`uff> rinoa non sono romantico, sono un semi-isolato che fantastica su cose che non potranno mai accadere
    <Drg`uff> ma no
    <Drg`uff> che m3rda isolato
    <Drg`uff> mettici nerd
    <prm\\> drag, siamo in due
    <Ed\\> anche 3 dai

  8. #8
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    Inviato da Prometeo
    Hai settato l'autenticazione PAP?
    come si fa?
    attivando l'interfaccia appare anche:
    Binding PPP device: ippp0 or : Device or resource busy

  9. #9
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    adesso ho reinstallato l'intero sistema isdn. ho scoperto che il modulo hisax non si carica se gli si passa il parametro type=XX. purtroppo questo parametro indispensabile x riconoscere il TA

  10. #10
    Utente GNU/Linux
    Registrato il
    10-02
    Localit
    Roma
    Messaggi
    3.246
    Inviato da devilheart
    adesso ho reinstallato l'intero sistema isdn. ho scoperto che il modulo hisax non si carica se gli si passa il parametro type=XX. purtroppo questo parametro indispensabile x riconoscere il TA
    Nel 2.4 tenevo Hisax integrato nel kernel con il supporto solo per il mio chipset e fungeva senza nemmeno doverlo caricare, prova cos.

  11. #11
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    fatto. ora il hisax funziona, tuttavia x attivare l'interfaccia ippp0 devo anche caricare il modulo hisax_hfcpci
    cosa significa Binding PPP device: ippp0 or : Device or resource busy quando faccio ifup ippp0 ?

  12. #12
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    come ho detto prima ho configurato hisax comu built-in e attviando il supporto solo x la mia scheda (tralatro c' scritto Asuscom ISA cards mentre la mia pci), per all'avvio hisax dice che la scheda di tipo 12 (la mia in base alla documentazione di hisax) non installata. adesso ho provato a rimetterlo come modulo ma quando lo carico (
    # modprobe hisax type=12 irq=5 io=0xb800
    )
    da errore. l'errore localizzato in type=12, proprio nel parametro che informa il modulo quale scheda utilizzata...

  13. #13
    Utente GNU/Linux
    Registrato il
    10-02
    Localit
    Roma
    Messaggi
    3.246
    Inviato da devilheart
    come ho detto prima ho configurato hisax comu built-in e attviando il supporto solo x la mia scheda (tralatro c' scritto Asuscom ISA cards mentre la mia pci), per all'avvio hisax dice che la scheda di tipo 12 (la mia in base alla documentazione di hisax) non installata. adesso ho provato a rimetterlo come modulo ma quando lo carico (
    # modprobe hisax type=12 irq=5 io=0xb800
    )
    da errore. l'errore localizzato in type=12, proprio nel parametro che informa il modulo quale scheda utilizzata...
    Infatti non quella la tua scheda, se non sbaglio una HFC PCI-Bus card
    (io usavo la tua stessa scheda, ed il chipset per il modello PCI diverso da quello delle ASUSCOM ISA , all'inizio c'ero cascato anch'io! )

  14. #14
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    questo preso dal file README:HiSax:
    1 Teles 16.0 irq, mem, io
    2 Teles 8.0 irq, mem
    3 Teles 16.3 (non PnP) irq, io
    4 Creatix/Teles PnP irq, io0 (ISAC), io1 (HSCX)
    5 AVM A1 (Fritz) irq, io
    6 ELSA PCC/PCF cards io or nothing for autodetect (the iobase is
    required only if you have more than one ELSA
    card in your PC)
    7 ELSA Quickstep 1000 irq, io (from isapnp setup)
    8 Teles 16.3 PCMCIA irq, io
    9 ITK ix1-micro Rev.2 irq, io
    10 ELSA PCMCIA irq, io (set with card manager)
    11 Eicon.Diehl Diva ISA PnP irq, io
    11 Eicon.Diehl Diva PCI no parameter
    12 ASUS COM ISDNLink irq, io (from isapnp setup)
    13 HFC-2BS0 based cards irq, io
    14 Teles 16.3c PnP irq, io
    15 Sedlbauer Speed Card irq, io
    15 Sedlbauer PC/104 irq, io
    15 Sedlbauer Speed PCI no parameter
    16 USR Sportster internal irq, io
    17 MIC card irq, io
    18 ELSA Quickstep 1000PCI no parameter
    19 Compaq ISDN S0 ISA card irq, io0, io1, io (from isapnp setup io=IO2)
    20 NETjet PCI card no parameter
    21 Teles PCI no parameter
    22 Sedlbauer Speed Star (PCMCIA) irq, io (set with card manager)
    24 Dr. Neuhaus Niccy PnP irq, io0, io1 (from isapnp setup)
    24 Dr. Neuhaus Niccy PCI no parameter
    25 Teles S0Box irq, io (of the used lpt port)
    26 AVM A1 PCMCIA (Fritz!) irq, io (set with card manager)
    27 AVM PnP (Fritz!PnP) irq, io (from isapnp setup)
    27 AVM PCI (Fritz!PCI) no parameter
    28 Sedlbauer Speed Fax+ irq, io (from isapnp setup)
    29 Siemens I-Surf 1.0 irq, io, memory (from isapnp setup)
    30 ACER P10 irq, io (from isapnp setup)
    31 HST Saphir irq, io
    32 Telekom A4T none
    33 Scitel Quadro subcontroller (4*S0, subctrl 1...4)
    34 Gazel ISDN cards (ISA) irq,io
    34 Gazel ISDN cards (PCI) none
    35 HFC 2BDS0 PCI none
    36 W6692 based PCI cards none
    37 HFC 2BDS0 S+, SP irq,io
    38 NETspider U PCI card none
    39 HFC 2BDS0 SP/PCMCIA irq,io (set with cardmgr)
    40 hotplug interface
    41 Formula-n enter:now PCI none

    ora ho provato a compilare il modulo hisax attivano solo il supporto per HFC PCI-Bus card ( dovrebbe essere il type 35) ma quando carico il modulo vai tutto in crash e nn ci sono messaggi nei log. ho provato anche a compilarlo built-in ma il sistema si blocca all' avvio.

  15. #15
    Utente L'avatar di devilheart
    Registrato il
    01-03
    Messaggi
    28.311
    ora uscita la prima versione stabile del 2.6.0 e quindi l'ho installato ma il problema persiste. si pianta tutto durante il caricamenti del modulo.

Pag 1 di 2 12 UltimoUltimo

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •