• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Visualizzazione risultati da 1 a 6 di 6

Discussione: Python

Cambio titolo
  1. #1
    gymvideo
    Ospite

    Python

    Chi forse l'avrà capito, voglio cambiare linguaggio per passare a linux.

    Volevo sapere una cosa, come faccioa creare un file eseguibile per python 1.5.2? So già dell'esistenza di py2exe, ma non è per la versione del python che ho.

  2. #2
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    Località
    Midwich Street
    Messaggi
    6.699
    Se sei su Linux ti basta creare uno script, ad esempio ciao_mondo.py e passarlo all'interprete:
    Codice:
    [email protected]:~$ python ciao.py
    Ciao mondo!
    Se fai iniziare lo script con la linea#!/usr/bin/env python potrai anche semplicemente lanciarlo da console:

    Codice:
    [email protected]:~$ ./ciao.py
    Ciao mondo!
    [email protected]:~$


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  3. #3
    gymvideo
    Ospite
    per adesso sono ancora su windows... ma come faccio ad aprire un file .py sull'interprete in questo odiabile OS? grazie

  4. #4
    Utente L'avatar di QWE
    Registrato il
    10-02
    Località
    Taranto
    Messaggi
    80
    Premetto che non ho mai usato la 1.5.2.

    Per creare eseguibili su windows ci sono diverse utility. http://www.mcmillan-inc.com/install1.html
    Personalmente ho solo utilizzato py2exe, e anche poco non avendo la grande necessità di distribuire i miei programmi.

    Se invece, da quello che capisco dal secondo post, è di eseguirli sul tuo pc, aggiungi il path di python.exe alla variabile PATH del tuo autoexec.bat.

    P.S. Come mai usi una versione così obsoleta?
    qweeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee

  5. #5
    gymvideo
    Ospite
    Inviato da QWE

    P.S. Come mai usi una versione così obsoleta?

    xkè è quella che misura meno

  6. #6
    Utente L'avatar di QWE
    Registrato il
    10-02
    Località
    Taranto
    Messaggi
    80
    Io ti consiglio comunque di scaricare almeno la 2.1. Rispetto alla 1.5, le 2.x sono più perfomanti, hanno nuove funzioni built-in che prima o poi andresti ad utilizzare, hanno una collezione di librerie molto più ampia ed hanno introdotto alcune variazioni significative nel linguaggio.

    Quest'ultimo punto si traduce che avrai quasi certamente bisogno di mettere mani sul codice per far girare correttamente un tuo programma 1.5 con l'interprete 2.x.

    Se questo ancora non ti basta, ti risulterà ostico trovare versioni recenti di moduli di terze parti (che già stanno abbandonando lo sviluppo per la 2.1).

    In definitiva scaricati i 9.3 MB della 2.3.3 (sfornata 3 giorni fa!!!). Anche se ci impiegherai un pò per scaricarla, risparmierai un sacco di tempo quando ti metterai a programmare
    qweeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •