• In diretta da GamesVillage.it
    • News
    • -
    • In Evidenza
    • -
    • Recensioni
    • -
    • RetroGaming
    • -
    • Anteprime
    • -
    • Video
    • -
    • Cinema

Visualizzazione risultati da 1 a 14 di 14

Discussione: MPlayer 1.0pre3

Cambio titolo
  1. #1
    Utente L'avatar di Marko
    Registrato il
    10-02
    Messaggi
    37.168

    MPlayer 1.0pre3

    Con i pacchetti di MDK92 avevo già installato MPLayer 0.9.x.
    Ho scaricato i sorgenti di MPlayer v1.0pre3 dal sito ufficiale e li ho compilati con i comandi

    # ./configure
    # make
    # make install

    Però, dopo l'ultimo comando, non ho capito in che cartella ha effettuato l'installazione...come posso richiamarlo?

  2. #2
    Utente L'avatar di Marko
    Registrato il
    10-02
    Messaggi
    37.168
    Sgtbash mi ha consigliato di usare il comando che usa KDE per avviare la versione vecchia e cioè

    /usr/bin/gmplayer -quiet -nofs %U

    da trasformare in

    $ ./mplayer -quiet -nofs %U

    nella directory dei sorgenti. Una volta fatto però mi appare questo: http://www.markoit.net/images/konsole2.png


  3. #3
    Contegno, suvvia! L'avatar di Prometeo
    Registrato il
    10-02
    Località
    New York
    Messaggi
    7.890
    Non ho capito: vuoi solamente avviare mPlayer?
    the e.caffeinomane Xperience
    <Drg`uff> rinoa non sono romantico, sono un semi-isolato che fantastica su cose che non potranno mai accadere
    <Drg`uff> ma no
    <Drg`uff> che m3rda isolato
    <Drg`uff> mettici nerd
    <prm\\> drag, siamo in due
    <Ed\\> anche 3 dai

  4. #4
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    Località
    Midwich Street
    Messaggi
    6.699
    Inviato da Marko
    Sgtbash mi ha consigliato di usare il comando che usa KDE per avviare la versione vecchia e cioè

    /usr/bin/gmplayer -quiet -nofs %U

    da trasformare in

    $ ./mplayer -quiet -nofs %U

    nella directory dei sorgenti. Una volta fatto però mi appare questo: http://www.markoit.net/images/konsole2.png

    E grazie a gatsu, devi passargli il nome di un file
    $ ./mplayer nomefile.avi


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  5. #5
    Moderatore Apple L'avatar di sgtbash
    Registrato il
    10-02
    Località
    Catania
    Messaggi
    8.296
    Inviato da Phoenix
    E grazie a gatsu, devi passargli il nome di un file
    $ ./mplayer nomefile.avi
    Ah già, vabbè la prima parte era corretta

    An a day keeps microsoft away | Il nostro punto di Vista? Mac OS X 10.5 Leopard

    Moderazione in rosso e grassetto. Chiarimenti ne Il forum del forum o in privato.

  6. #6
    Utente L'avatar di Marko
    Registrato il
    10-02
    Messaggi
    37.168
    Ah, tnx, domani provo

  7. #7
    Utente GNU/Linux
    Registrato il
    10-02
    Località
    Roma
    Messaggi
    3.246
    Prima di fare il # make install hai disinstallato il pacchetto della Mandrake?
    Cmq i binari vengono installati quasi sempre in:
    /usr/bin
    o
    /usr/local/bin
    I binari in quelle cartelle possono venir eseguiti semplicemente digitandone il nome in qualsiasi momento (in shell o campi appropriati, ovviamente).
    Se non l'hai disintallato, sappi che probabilmente avrai sovrascritto dei files, forse generato conflitti fra le 2 versioni, e potrebbe essere una buona idea disinstallare entrambe e poi reinstallarne una, convenientemente quella della Mandrake per risparmiarti problemi di dipendenze ed integrazioni, e potendo sempre eseguire la versione compilata dai sorgenti richiamando il binario contenuto all'interno della cartella con i suddetti.
    # cd cartellasorgentiMPlayer && make uninstall && urpme mplayer && urpmi pacchetti rimossi da urpme

  8. #8
    Utente Gentoo Gnu/Linux L'avatar di []\/[]aStEr-HaCk
    Registrato il
    06-03
    Località
    /dev/sda6
    Messaggi
    1.663
    Scusa marko, ma perchè non usi Gmplayer? L'ho provato, ed è molto carino, anche più semplice da utilizzare


    [email protected] ~ $ uname -a
    Linux venice64 2.6.15-gentoo-r5 #1 Wed Apr 12 18:48:03 GMT 2006 x86_64 AMD Athlon(tm) 64 Processor 3500+ AuthenticAMD GNU/Linux

  9. #9
    Utente L'avatar di Marko
    Registrato il
    10-02
    Messaggi
    37.168
    Inviato da Nonno Cicala
    Prima di fare il # make install hai disinstallato il pacchetto della Mandrake?
    Cmq i binari vengono installati quasi sempre in:
    /usr/bin
    o
    /usr/local/bin
    I binari in quelle cartelle possono venir eseguiti semplicemente digitandone il nome in qualsiasi momento (in shell o campi appropriati, ovviamente).
    Se non l'hai disintallato, sappi che probabilmente avrai sovrascritto dei files, forse generato conflitti fra le 2 versioni, e potrebbe essere una buona idea disinstallare entrambe e poi reinstallarne una, convenientemente quella della Mandrake per risparmiarti problemi di dipendenze ed integrazioni, e potendo sempre eseguire la versione compilata dai sorgenti richiamando il binario contenuto all'interno della cartella con i suddetti.
    # cd cartellasorgentiMPlayer && make uninstall && urpme mplayer && urpmi pacchetti rimossi da urpme

    La versione della Mandrake però è quella più vecchia. Comunque, non mi pare ci siano conflitti tra le due versioni visto che facendo come dice Phoenix posso avviare un file da Konsole con MPlayer 1.0pre3 oppure, tramite icona dal menu principale, MPlayer 0.9. Però non capisco una cosa.
    Sul Desktop ho due icone: MPlayer 0.9 (messa da Mandrake) e MPlayer 1.0pre3 (messa io come collegamento simbolico, presa dai sorgenti). Se faccio doppio click sulla prima il player parte in modo grafico con menù visuale e roba varia permettendomi di muovermi nelle varie opzioni. Se faccio doppio click sulla seconda non succede niente, devo per forza avviarlo da Konsole dandogli direttamente in pasto un file da leggere. In questo modo però non usufruisco del menu (quindi non posso andare avanti, indietro, ecc.), vedo soltanto la finestra in cui viene riprodotto il video. Come faccio per avviare la 1.0pre3 come la 0.9?

  10. #10
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    Località
    Midwich Street
    Messaggi
    6.699
    L'interfaccia grafica di MPlayer (quella che ti parte quando clicchi sulla 0.9) è gMPlayer, devi quindi scaricarti anche questo nella sua ultima versione e poi fare il collegamento a lui


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  11. #11
    Utente L'avatar di Marko
    Registrato il
    10-02
    Messaggi
    37.168
    Effettivamente il link di MPlayer 0.9 era gMPlayer...strano o_O

    Trovo l'interfaccia grafica sempre sul sito di mp?

    EDIT: http://lists.debian.org/debian-user/.../msg00447.html
    gmplayer = mplayer with it's gui enabled
    LOL -__-

    Uhm...non so da dove scaricare la gui 8|
    Ultima modifica di Marko; 26-12-2003 alle 19:39:03

  12. #12
    Utente GNU/Linux
    Registrato il
    10-02
    Località
    Roma
    Messaggi
    3.246
    Inviato da Marko
    Effettivamente il link di MPlayer 0.9 era gMPlayer...strano o_O

    Trovo l'interfaccia grafica sempre sul sito di mp?

    EDIT: http://lists.debian.org/debian-user/.../msg00447.html
    gmplayer = mplayer with it's gui enabled
    LOL -__-

    Uhm...non so da dove scaricare la gui 8|
    Non devi scaricarla, ma compilarla.
    Ti pasta dare l'opzione --enable-gui al configure di MPlayer.
    $ ./configure --enable-gui && make
    Lo so che il sistema detto da Phoenix funge, perché in quel modo funzionerebbe come se non l'avessi installato, in pratica non usi i files installati dai sorgenti (da # make install , usi invece quelli compilati senza averli installati).
    Il fatto che i collegamenti già presenti nella MDK funzionino, è o perché usano percorsi assoluti, o per coincidenza la shell cerca prima nel percorso /usr/bin e dopo in /usr/local/bin dove più probabilmente hai la versione installata ed inutilizzata di Mplayer compilata dai sorgenti.

  13. #13
    Utente L'avatar di Phoenix
    Registrato il
    10-02
    Località
    Midwich Street
    Messaggi
    6.699
    Un consiglio spassionato: tieniti la versione stabile.
    Io ho la 1.0-pre3 e dopo circa un'ora e mezza di funzionamento mi sale la cpu al 100% rallentando mplayer, costringendomi a chiuderlo e riavviarlo, oggi addirittura mentre aprivo un file (realmedia, ero stato avvertito che non c'era il supporto ma, anche se basilarmente, me lo faceva vedere perciò ho lasciato correre...) mi ha riavviato X


    He who is not bold enough to be stared at from across the abyss
    is not bold enough to stare into it himself.

  14. #14
    Utente L'avatar di Skyflash
    Registrato il
    12-02
    Località
    127.0.0.1
    Messaggi
    3.672

    Re: MPlayer 1.0pre3

    Inviato da Marko
    Però, dopo l'ultimo comando, non ho capito in che cartella ha effettuato l'installazione...come posso richiamarlo?
    Beh, solitamente tutto va in /usr/bin , ma dove realmente vada non e' che debba essere problema tuo

    Se poi lo vorrai disinstallare, potrai sempre provare a dare un make uninstall da dentro la cartella che hai usato per compilare mplayer.

    Come dici? Che in questo modo ti troverai a tenere sempre cartelle originali ed eseguibili compilati? Certo. Ecco perche' l'altra sera ti ho consigliato di usare i precompilati in .rpm anziche' le compilazioni

    Sara' una pratica meno "linuxiana", ma e' decisamente piu' pratico
    Lo Skyblog e' su www.skyflash.it
    Wiitiful Sky su XBox Live
    WiitifulSky sul PSN
    Il mio codice Wii: 2634 4285 3158 4638

Regole di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •